Brothersoft.comWindows|Mac|Mobile|Games

|Message

Solve software problem quickly Share experience to help others Improve the ability of solving problem
Windows Media Player 12 "Rip Music" settings not working

11/21/2011 12:38 by JohnEverard

Running new Windows 7-equipped PC built by a VERY reputable high-end build company.

WMP12 working OK but two (2) possibly related problems are presenting themselves in WMP12.

Within WMP12:

1) Under Tools/Options/Rip Music, the "Rip music to this location" field is blank. When I click "Change..." nothing happens. No dialog, error or anything else other than the [Change...] button flashing to acknowledge the click. I did move my "personal folders" locations to a drive other then C:, but have verified that they are correctly mapped and that the "My Music" Library is "functional" and is visible via the Files/Manage Libraries option in WMP12.

2) Also under Tools/Options/Rip Music, ANY other change (for example, a change to the quality slider), will not "take" when the [Apply] button is clicked. Instead, a dialog box appears stating "The settings for ripping music could not be applied".

Again, this was a OEM build from a great company. Everything else is working correctly (I am an self-proclaimed Windows Guru).

I have refreshed libraries

I have deactivated WMP from the functions and features tool, rebooted, run a registry cleaner, reactivated and the problem still exists.

I have found no way to do a clean reinstall of WMP
First answer posted by Artemaria at 11/21/2011 12:38
Add Your Answer
10~1000 characters in length CAPTCHA:
15 Answers
  • Anonymous user
  • Click File - Manage libraries - Music and remove folders that no longer exist from the list. The default location will then appear in the "Rip music to this location" field. You can then change the location.
  • Was this answer helpful? 10 · 12/19/2011 20:22
  • Artemaria
  • Hi ,
    I suggest you to run the Media player troubleshooter.
    Run the Media Player troubleshooter:
    Open the Windows Media Player  troubleshooter by clicking the Start button, and then clicking Control Panel. In the search box, and then 
    click Troubleshooting. Click View all, and then click Windows Media Player settings.
  • Was this answer helpful? 00 · 11/21/2011 12:38
  • BrianHimlie
  • I am having the same problem.  In addition, if I try to change the rip settings from WMA to MP3, I get an error say Window Media Player cannot do that.
  • Was this answer helpful? 00 · 11/21/2011 12:41
  • Kimplex
  • This is because the directory where rip use to point to no longer exsits. Try remaking the path to were rip used to point to (no need to re-move your whole personnel folders just create the path to were rip pointed to then you can delete afterwards) , as soon as you have the right path made, the rip dialogue in WMP will show up again and you will be able to change it. Also see this post, i understand from your OP Angie that you have done most of this but see my post at the bottom might give you a hint as to were rip pointed to if you cant remember.
  • Was this answer helpful? 00 · 11/21/2011 12:41
  • PollyP
  • After creating the folder C:\Users\username\Music, I was able to see, and change the destination folder in WMP12.  Additionally, all the other Rip settings can now be changed and "take" when the [apply] button is clicked.
    Note to Microsoft:  This HAS to be a bug and needs to be fixed (with an actual fix or at least a more descriptive error message).  I can't be the only person that wanted to change the location of their Music folder off of the default C: drive location (especially when one's C: drive is an expensive SSD like mine).
    Thanks again SaNiC.  You are my hero.
  • Was this answer helpful? 00 · 11/21/2011 12:41
  • NataliaPeterson
  • I had the same problem. Do the following:
    Start right click Music and get the properties.
    Make sure you include this path c:\users\"your user"  
    This will add My Music folder from the above path
    I had removed the above path, re-adding it and clicking apply fixed my issue.
    Hope it works for you to
  • Was this answer helpful? 00 · 11/21/2011 12:42
  • Anonymous user
  • here is what worked for me: Open Explorer, under Libraries expand 'music', app any folder to it. Then change settings for rip folder in MP. You can remove folder from the library (or leave it) and done...
  • Was this answer helpful? 00 · 01/01/2012 21:51
  • Anonymous user
  • Thank you so much for your help........ after reading this I went to LIBRARIES under Start Clicked on Music Clicked RESTORE DEFAULT settings and voila now it works thanks again
  • Was this answer helpful? 00 · 04/18/2012 07:57
  • Anonymous user
  • Try to run the native wmplayer.exe If you run this it will sure failed"%ProgramFiles(x86)%\Windows Media Player\wmplayer.exe" /prefetch:1 Try the 64 bit version (it run perfectly for me), everything can be change"%ProgramFiles%\Windows Media Player\wmplayer.exe" /prefetch:1 I am not sure what is the reason
  • Was this answer helpful? 00 · 11/01/2012 15:52
  • Anonymous user
  • NataliaPeterson - YOU ARE AWESOME!!!  Your fix worked for me perfectly - much thanks:)
  • Was this answer helpful? 00 · 03/24/2013 17:14
  • Anonymous user
  • this shit gets on my nerves i hate yall

  • Was this answer helpful? 00 · 04/11/2013 18:08
  • Anonymous user
  • Solution that worked for me (Mediaplayer 12):

    Got the same problem, the cd rip path did not exist anymore after reconfigure my NAS. Forget about solutions like troubleshooters and registry.

    In Mediaplayer choose "organize" --> "Manage Libraries" (got the German version, hope to guess the Name correctly) --> Music You should see here your library is not available. Just remove it! After this your "Rip path button" will work again :-)

  • Was this answer helpful? 00 · 06/06/2013 06:25
  • Anonymous user
  • Just upgraded to Win8.1 and encountered this same problem that was not present with the OEM install of Win8.  Followed the advice in the post immediately above my post (dated 6/6/13) and found two directories in the manage libraries window.  Deleted one that didn't look familiar to me, left the one that was C:/User/<my name>/Music and that fixed the problem for me.
  • Was this answer helpful? 00 · 12/25/2013 20:46
  • Anonymous user
  • what if I don't know the old path? It's fresh install of Windows 8.1. I think it took the settings from the cloud (from previous configuration), but I changed the drives letters etc. Besides I changed the rip path on the previous instalation. What's more this system is installed from a diffrent CD - 8.1 instead of 8, with different language. what to do? Reinstall Windows without taking the old settings from the cloud?
  • Was this answer helpful? 00 · 08/14/2015 19:18
  • Anonymous user
  • I had a similar situation to this.  I found that I had to do the following. 1) Use Windows Explorer and go to Libraries.

    2) Delete the Music folder (as mine was broken there was no way to repair it)

    3) Create a new Music folder in the same location.

    4) Double click the Music folder and select the folder it should include.  (Most systems default to C:/Users/[user name]/My Music) 5) Open Windows Media Player, and all should be well with the world.

  • Was this answer helpful? 00 · 02/14/2016 18:15
Add Your Answer
10~1000 characters in length CAPTCHA:

Added Successfully!

×

Are you sure to delete your answer?

NoYes

×

Are you sure to choose it as the best answer?

NoYes

×

Voted Successfully!

×

You can't vote for yourself

×

You can't choose your own answer

×