Brothersoft.comWindows|Mac|Mobile|Games

|Message

Solve software problem quickly Share experience to help others Improve the ability of solving problem
how can I edit Visio 2010 swimlanes' depth/height?

02/21/2012 06:20 by MikeChin

I'd like to minimize the size of the diagram. how can i gain full control control over Visio 2010 swimlanes' depth/height? Visio seems to inconsistently dictate swimlane depth/height which limits my ability to produce simple and professional looking diagrams.
First answer posted by NataliaPeterson at 02/21/2012 06:21
Add Your Answer
10~1000 characters in length CAPTCHA:
11 Answers
  • NataliaPeterson
  • In 2010, if a shape extends beyond the enod of a page, the page grows so the shape remains on the page. If you move items back on to the original page, the extra page disappears. So you can control the swimlane widths by moving the shapes or using Relayout on the Layout Ribbon.
    What do you mean by inconsistently? The swimlane should take the width of a page and if shapes are added beyond the page, another page is added and the swimlane is extended to the end of that page.
  • Was this answer helpful? 00 · 02/21/2012 06:21
  • PollyP
  • If you select the main CFF Container shape, then open it's ShapeSheet, you will see that there is a User.visMargins cell. The value in this cell is the minimum distance around the flowchart shapes in a lane (I think). YOu can reduce this value to allow the lanes to be reduced in height...
    If you do this edit to the master in the document stencil, then it will apply it to all instances of the CFF Container in your document.
  • Was this answer helpful? 00 · 02/21/2012 06:22
  • BrianHimlie
  • Swimlanes are less of a mouthfull than Cross Functional Flowcharts (the name used in Visio).
  • Was this answer helpful? 00 · 02/21/2012 06:22
  • Anonymous user
  • To be able to see the ShapeSheet, you need to go to File, Options and then tick the Run in Developer mode box under Advanced\General.

    You can also tell Visio not to show the Phase box if you don't need it as this will reduce the size a bit.  To do this, set User.visShowPhase to 0, but make sure you click on the whole swimlane and not just the Phase box or you won't be able to see it.

  • Was this answer helpful? 00 · 06/26/2012 14:28
  • Anonymous user
  • Here are the instructions:

    Click File/Options/Advanced. Scroll down to General.  Check 'Run in developer mode'.

    In the title of each swimlane, click Show ShapeSheet.

    In the User-defined Cells section, find User.msvSDContainerMargin.  In the Value Column type 0.

    After this is complete, you can edit the width/depth of each swimlane without Visio moving things around randomly.

  • Was this answer helpful? 00 · 07/08/2013 16:08
  • Anonymous user
    • Anonymous user
    • Here are the instructions:

      Click File/Options/Advanced. Scroll down to General.  Check 'Run in developer mode'.

      In the title of each swimlane, click Show ShapeSheet.

      In the User-defined Cells section, find User.msvSDContainerMargin.  In the Value Column type 0.

      After this is complete, you can edit the width/depth of each swimlane without Visio moving things around randomly.

    This worked for me! Thanks a lot!!

  • Was this answer helpful? 00 · 11/26/2013 21:50
  • Anonymous user
  • Anonymous user
  • Here are the instructions:

    Click File/Options/Advanced. Scroll down to General. Check 'Run in developer mode'.

    In the title of each swimlane, click Show ShapeSheet.

    In the User-defined Cells section, find User.msvSDContainerMargin. In the Value Column type 0.

    After this is complete, you can edit the width/depth of each swimlane without Visio moving things around randomly.

  • GENIUS - readers ignore all the earlier answers - this is it!
  • Was this answer helpful? 00 · 09/02/2014 11:16
    • Anonymous user
    • Thank you wonderfulness of the internet ... first link on search and worked perfectly - thanks!!!
    • Was this answer helpful? 00 · 10/08/2014 19:31
    • Anonymous user
    • Hi,

      I also found that sometimes I am unable to see the usual resizing handles (blue squares at the corners and middle of lines) on the object, so if you goto the Miscellaneous Field a little further down on the ShapeSheet tools you will see the NoObjHandles, I have changed this to False and this also enables the free handed resizing.

    • Was this answer helpful? 00 · 03/19/2015 02:29
    • Anonymous user
    • Go to Home > Under 'Editing' click Select > Area Select. You should be all set to resize the swim lanes.
    • Was this answer helpful? 00 · 12/15/2015 20:33
    • Anonymous user
      • Here are the instructions:

        Click File/Options/Advanced. Scroll down to General.  Check 'Run in developer mode'.

        In the title of each swimlane, click Show ShapeSheet.

        In the User-defined Cells section, find User.msvSDContainerMargin.  In the Value Column type 0.

        After this is complete, you can edit the width/depth of each swimlane without Visio moving things around randomly.

      **** THIS IS THE SOLUTION! ****

      Bravo to the original poster of this solution. I can't believe the solution is convoluted to do something that should be basic.

    • Was this answer helpful? 00 · 01/20/2016 18:25
    Add Your Answer
    10~1000 characters in length CAPTCHA:

    0 people are following

    Ask a question now
    Write a title for your question

    Microsoft Office Visio

    Helping visualize,analyze,communicate complex information,systems,and processes.
    Latest version:2007
    License:Shareware
    OS:Windows XP
    Total downloads:440,491
    Rank:1 in Other Image Tools
    Download It

    Share with friends

    New features is coming

    • 1. Providing high-quality answers to be a verified Q&A expert
    • 2. Ask and answer questions to get Brothersoft credits

    Added Successfully!

    ×

    Are you sure to delete your answer?

    NoYes

    ×

    Are you sure to choose it as the best answer?

    NoYes

    ×

    Voted Successfully!

    ×

    You can't vote for yourself

    ×

    You can't choose your own answer

    ×